Skip to main content

GUI description

Menus

  • File
    • New – Creates a new file with new configuration.
    • Open… – Opens a specified *.mtbsensor configuration file. The current configuration file, if any, will be closed. If there are unsaved changes, a dialog opens asking to save or not.
    • Close – Closes the current configuration file.
    • Save – Saves the current configuration file.
    • Save As… – Saves the existing file under a different name.
    • Open in System Explorer – This opens your computer’s file explorer tool to the folder that contains the *.mtbsensor configuration file.
    • Recent files – Shows recent files that you can open directly.
    • Exit – Closes the tool. You will be prompted to save any pending changes.
  • Edit
    • Undo – Undoes the last action or sequence of actions.
    • Redo – Redoes the last undone action or sequence of undone actions.
  • View
    • Notice List – Hides or shows the Notice List pane. The pane displays by default.
    • Toolbar – Hides or shows the Toolbar.
    • Reset View – Resets the view to the default.
  • Help
    • View Help – Opens this document.
    • About Sensor Designer tool – Opens the About box for version information, with links to open https://www.infineon.com and the current session log files of the application.

Toolbar

The toolbar contains common commands from the File and Edit menus. Use the check box under the View menu to show or hide the toolbar.



Sensor tabs

There are three tabs on the Sensor Designer tool interface:

The sensor tabs represent the relevant sensor configuration. A tab contains a set of parameters to configure the settings of a sensor drawing pattern and generate it to the *.dxf file.

The tab name is provided as the default name for the generated *.dxf file.



Commands

  • Restore Defaults – Restores parameters values on the current tab to their default values.
  • Copy All – Click this button to copy the list of input and output parameters to the system clipboard as plain text.

Select sensor

To create new tab configuration, click New on the File menu. It will display the "Select sensor" dialog.



  • Sensor type – Liquid Level, Button, Radial Slider.
  • Sensing method – CSD for Liquid Level and Radial Slider, ISX for Button.

Move actions

  • To add a tab for a new level, click the green (+) button to display the "Select sensor" dialog.
  • To remove a tab, click the red (-) button.
  • To rename the sensor, double-click its name.
  • To change the tabs order, left-click a tab name and drag it to the preferred position.
Generate DXF

Click this button to generate a *.dxf file of the calculated sensor to a specified file location.



Last updated on